Unity Pro Error Message

Chipmunk2D Bindings for the Unity3D engine

Unity Pro Error Message

Postby Roland » Thu May 15, 2014 11:45 am

I'm running the full version of Unity Pro 4.3.4f1 with the 'Latest' Chipmunk2D Package and I keep getting an error message in the console stating that I am "running Unity Free and have not run the Chipmunk setup." The "Setup Chipmunk2D for Unity Free" option in the component menu is greyed out, as I'd expect, but this error message keeps popping up.

Looking at the source code generating the message (ChipmunkEditor.cs - line 146) I'm seeing that the ChipmunkMenus static constructor seems to be checking if it is necessary to run the Unity Free setup and storing the value in an IS_SETUP static bool, then subsequently logging the error that I'm seeing regardless of it's value. I'm assuming it's just missing a simple if(!IS_SETUP) before actually logging the error.

A simple fix and not really a big deal, but I figure I'd point it out to be fixed in the next release.
Apologies if this has already been addressed somewhere in the forums, I did a quick search and didn't quite find the droid I was looking for.
User avatar
Roland
 
Posts: 16
Joined: Thu Aug 08, 2013 3:32 pm

Return to Chipmunk2D for Unity

Who is online

Users browsing this forum: No registered users and 1 guest

cron