CMake won't build, project variables are turned off.

Discuss any Chipmunk bugs here.

CMake won't build, project variables are turned off.

Postby blakat1033 » Sun Sep 04, 2016 12:17 pm

Using the tuitorial on this site I try to build a make file using cmake only to have this happen. How can I fix this?

blakat@blakat-desktop:~/Chipmunk-7.0.1$ cmake -D CMAKE_BUILD_TYPE=Debug .
Configuring Chipmunk2D version 7.0.1
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
GLEW_INCLUDE_DIR
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
GLEW_LIBRARIES
linked by target "chipmunk_demos" in directory /home/blakat/Chipmunk-7.0.1/demo
GLFW_INCLUDE_DIR
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
used as include directory in directory /home/blakat/Chipmunk-7.0.1/demo
GLFW_LIBRARIES
linked by target "chipmunk_demos" in directory /home/blakat/Chipmunk-7.0.1/demo

-- Configuring incomplete, errors occurred!
See also "/home/blakat/Chipmunk-7.0.1/CMakeFiles/CMakeOutput.log".
blakat1033
 
Posts: 2
Joined: Sun Sep 04, 2016 11:32 am

Re: CMake won't build, project variables are turned off.

Postby slembcke » Tue Sep 06, 2016 11:15 am

Looks like you are using Linux of some flavor? Make sure you have GLEW and GLFW2 installed. That's what CMake is trying to tell you.
Can't sleep... Chipmunks will eat me...
Check out our latest projects! -> http://howlingmoonsoftware.com/wordpress/
User avatar
slembcke
Site Admin
 
Posts: 4164
Joined: Tue Aug 14, 2007 7:13 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 2 guests

cron